
ArcGIS Pro – Session Two 
 

Creating Data and Editing Features 
 

The following step-by-step guide will help you to create new Feature Classes. This will help you to 

build upon Session One documents and continue to explore the ArcGIS Pro software, and where 

certain items and tools are located. This guide will again touch on some best practices for 

managing data and explore a few options for creating new data and editing not only shapes, 

but tabular data as well. 

 

Again you will be asked to build on previous documents “Create Your First Map”, and utilize skills 

learned in that session. You will create a new File Geodatabase and Feature Dataset. This new 

Feature Dataset will contain new Feature Classes of Points, Lines, and Polygons and ultimately 

new features that you will draw. 

 

 

 

Please note that ArcGIS software updates regularly and images may not be completely 

accurate to your screen view. Every attempt has been made to make the images as accurate 

as possible. 

 

 



 

 

 



1. Click the ArcGIS Pro icon from the Start Menu to open the software. 

 

 

 

 

 

 

 

 

 



2. Select “Start without a Template (you can save it later)”. Remember that there are 

training links at the right side – Those never used to be there, so make use of them and 

build your skill set. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



3. Click the Project Tab, then choose ‘Save As’. 

 

 

 

 

 

 

 

 

 

 

 



4. Navigate inside the Working Folder on the C Drive and Name the Project “Session Two – 

Creating Features and Editing”. Press “Save” to create the project. 

 

 

5. Again notice that on the Catalog Tab at the right side of the software under “Project”, 

there is another “Default.gdb”. Notice the location is different than the Default.gdb than 

was created in Session One. There isn’t anything in this Default.gdb yet. In the next step 

we will create a Feature Dataset. 

 

 



6. Right-click on the Default.gdb and then Hover on New. Choose “Feature Dataset”. 

 

 

 

 

 

 



7. Name this new Feature Dataset “Session_Two_Feature_Dataset”. Remember there can

be no spaces in the text, and special characters are limited. Choose NAD 1983 (2011) 
StatePlane Nebraska FIPS 2600 (US Feet)as the coordinate system.

8. Click “Run” at the bottom right to execute the creation tool.



9. Back on the Catalog Pane, the Feature Dataset is now visible. 

 



10. Right-Click on the Feature Dataset and again Hover on “New”. Choose “Feature Class”. 

 

 

 

 

 

 

 

 

 



11. Name this new Feature Class “Session_Two_BOUNDARY”. Make sure the Feature Class 

Type is Polygon. Go ahead and leave “Z Values- Coordinates include Z values used to 

store 3D data”    ---   checked.  

 

Leave the “Add output data to current map”  ---  checked. We don’t have a map yet, 

so nothing should appear when we run the tool anyway. 

 

 

 

 

 

 

 

 



12. Click “Finish” at the bottom of the “Create Feature Class” Pane. Note: this is a new pane 

opened when you selected “Create New Feature Class”. 

 



13. Right-Click the text for the new Feature Class and Hover on “Add to New”.  Then choose, 

“Map”. It will be projected based on the Feature Class that inherited the coordinate 

system from the Feature Dataset. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



14. Pan and zoom to any Game and Parks property in the State. Here, the author chose 

Long Pine SRA and Long Pine WMA. 

 

 

 

 

 

 

 

 

 

 

 



15. Notice in the Table of Contents that the Feature Class Alias name is displayed – 

“Boundary”, not the actual Feature Class name of “Session_Two_Boundary”. 

 

 
 

 

16. At the top of the screen, click the Edit Tab, then choose the Create icon. (It has a little 

pencil inside of it). 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 



17. Please note that only the Boundary layer is available here to create features. This is 

because no other features are in the Table of Contents. Many times users attempt to 

begin creating features but they have not added the class containing the features 

(Feature Class) into the document yet. 

 

 
 

18.  Click “Boundary” once to begin creating new features. 

 

 

 

 

 

 

 



19. The options at the top on the Edit Tab are visible. The icon for the cursor has changed 

too. 

 

20. At the bottom of the screen there are options for “How” to begin drawing features. 

Choose the first one that looks like a simple line segment for now. 

 

 

 

 

 

 

 



21. Pan and zoom closer to the boundary for a Game and Parks property. Use the scroll 

wheel on a mouse to zoom, or two fingers when using a laptop. Click once to creatte a 

vertex and begin drawing. 

 

 

22. Click agin to place another vertex. Notice how a polygon is starting to take shape. 

 

 

 

 

 



23. Notice here that the shape being traced along the east side has a slight jog in the line. 

Depending on one’s use, it may be a good idea to place a few more vertexes, but at a 

larger scale. Sometimes time is more valuable than precision when ultimately the 

boundary line’s thickness on a map or graphic would cover any such discrepancies 

anyway. 

 

 

 

 

 



24. Notice here that the boundary for Long Pine WMA is covered by the purple while 

attempting to draw. We will have to adjust the transparency before we continue 

drawing. 

 

 
 

25. As we learned in the first session, we an change the color and transparency by clicking 

the small polygon for any layer in the Table of Contents. Note: you will still be in “Editing 

Mode”, since you have not finished the feature or closed out of that tool. It is still the 

active tool. 

 

 



26. Click on Properties on the Symbology Tab to display how this polygon is ‘styled’. Then 

click the small purple box to change its color properties.  

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



27. Choose ‘color properties’ at the bottom. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



28. This opens the Color Editor dialogue window. Set the Transparency to about 85% to be 

able to see through the purple. Click OK. 

 

 
 

29. Click Apply on the Symbology pane to set that transarency to 85%. Then continue 

tracing. 

 

 
 

 



30. One is able to view both the new layer and anything underneath when the transparency 

is set just right. Please note: we could have just as easily turned OFF the Fill for this layer in 

the Symbology properties tab with one click. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



31. Press F2 to Finish the Sketch. Also, double-clicking can work, or right-click and choose 

‘Finish’. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



32. The sketch is completed for Long Pine WMA, but there is a major discrepancy in the 

shape towards the west. We will edit this next. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



33. Begin by clicking the “Select” tool on the Edit tab. This will release you from Edit mode. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 



34. Click the feature once to select it – this is now the “Select Set”. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



35. Zoom in to the area that needs repaired and again choose the Edit Tab. Choose the 

“Edit Vertices” icon near the middle. Not only will the vertices be visible now, but a new 

set of editing options are available at the bottom of the screen. 

 

 
 

 
 

 

 

 

 

 

 

 

 

 

 

 



36. Choose the icon that has a little minus sign on it. Notice that the cursor has changed its 

appearance to reflect the tool that is active. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

37. Drag a small box around the vertex that was placed incorrectly. It will be removed 

instantly. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



38. Note: a remnant of the original shape will exist until you save. This gives you one last 

chance to verify your edits. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 



39. On the Edit Tab, press the purple Save icon to save these edits. Please Note: Adding 

Features is considered an Edit, along with any editing of vertexes, or moving features and 

even editing of data, which we will get to eventually. For now, realize there are two 

different types of “Saves”. One saves edits to a database (Geodatabase, or other kinds 

of databases just containing scalar or tabular data), and another kind of Save saves the 

entire Pro Project document.  

 

 
 

40. Click Save at the upper left, or press control-s. Notice that after you saved the Edits, the 

purple Save button turned grey. This indicates there were no more “Pending Edits”. This is 

important to remember because sometimes, if there are pending edits, the software will 

not let you continue with other tasks. So, you sometimes have to save edits and get out 

of the Create Features activation in order to perform other Geoprocessing functions. 

 

 
 

 

 

 

 



41. Trace the remaining portions of the Game and Parks boundary that you chose.  

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 



42. Create two more Feature Classes. One for Lines and one for Points. Name them 

Session_Two_ROADS and Session_Two_TREES, respectively. Then add them to the Map 

View. You can choose “Add to Current Map”, or just drag and drop the layers from the 

Default.gdb into the Map View or even into the Table of Contents. 

 

  
 

43. Again, pick Create on the Edit Tab and choose the Roads layer in the Create Features 

“Pane” on the right side. Then trace roads around the property you chose. Pan and 

zoom as needed.  

 

 
 

44. Explore the various drawing tools, including the Arc Segment for drawing curves. 

“Faceting” a curve with many individual straight line segments is also an option. Again, 

the stroke of the line, when drawn, will conceal many irregularities of a faceted line. 

 

  
 

 

 

 

 



45. There is also a ‘Free Hand’ drawing tool, which is sometimes difficult to use… 

 

 
 

 

 

 

 

 

 

 

 

 

 

 



46. Here, only a few roads that were needed for this project have been traced. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



47. On the Map Tab, click the drop-down arrow for Basemap and choose Imagery. Note: 

this is ESRI provided imagery and it comes from a variety of sources. There is ZERO 

standardization for how accurate it is – No one knows. 

 

This problem is the same for any imagery provided by Google Maps/Google Earth and 

Bing Maps. Care MUST be taken and an understanding of this limitation must always be in 

mind. While sometimes imagery may have a higher resolution, there is no guarantee as 

to its accuracy. The only way is to go into the field with a surveyor and obtain 1/8th inch 

accuracy. 

 

 
 

 

 

 

 

 

 

 

 

 



48. The “ESRI Imagery” is now the basemap. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



49. Here, the trees have been plotted just to the north of Highway 20 but only in this Area of 

Interest using the Create Features tool. 

 

 
 

 



50. Remember to Save Edits, and also to save the Project often by pressing control-s. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



51. Right-click the Trees layer in the Table of Contents. Choose “Attribute Table”. The shortcut 

is control-t. 

 

 
 

52. The Attribute Table for this layer will open and it will usuallly be docked at the bottom of 

the screen. It can be dragged to another location, or even a separate monitor, if more 

space is needed. 

 

 
 

53. Click the text “Add” at the left side of the Attribute Table. Note: “Add” will not be 

available if there are Pending Edits. Save any edits using the purple save icon at the top, 

if needed. 

 

 



54. The Attribute Table’s Fields can be adjusted here in this new ‘Table’. Notice how the 

Attribute “Field Name” is automatically populated with the generic name “Field” and the 

Data Type is “Long”. 

 

 
 

55. Change Field Names, Aliases, Data Types, Number Format, and text field Length as 

follows: 

 

Field Name Alias Data Type Number Format Length 

tree_number Tree Number Short Numeric  

genus Genus Text  30 

species Species Text  50 

trunk_diameter Trunk Diameter in inches Float Numeric  

crown_diamteter Crown Diameter in Inches  Numeric  

observations Observations Text  255 

 

Note: The limitations for ArcGIS Data Types are found here:  ArcGIS field data types—

ArcMap | Documentation 

 

56. Press the purple Save icon at the top in the middle when finished, then close the Field 

editor. Please note this purple save icon is meant for the Attribute Table “Schema”. It is a 

different type of Save than for Edits, and different than an overall Project Save. 

 

 
 

 

 

 

 

 

 

 

 

https://desktop.arcgis.com/en/arcmap/latest/manage-data/geodatabases/arcgis-field-data-types.htm
https://desktop.arcgis.com/en/arcmap/latest/manage-data/geodatabases/arcgis-field-data-types.htm


57. The Attribute Table now has Fields available for data entry. 

 

 
 

58. In the Attribute Table, at the top of the field for “Tree Number” (note the Alias is now 

displayed there), right-click and choose, “Calculate Field”. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



59. Create the following calculation by first switching the “Expression Type” to “Arcade” by 

using the drop-down arrow, then double-click the Field “OBJECTID” to add it to the 

expression. You can then type in a calculation using the computer’s keyboard. 

 

Note: The little green check mark lets the software check the calculation to see if it is 

valid prior to running it. Click Apply to perform the calculation for that Field and every 

record. 

 

 



60. The Tree Numbers are filled in. These can be edited, if needed. Looking forward in the 

event that any new records for new trees are needed, there is space between the 

original numbers for those additions, such as 150, 160, 170, etc. 

 

 
 

61. One can also edit directly in each cell, like Microsoft Excel. So, there are less and less 

reasons to continue working in Excel. And certainly not to share information with others 

using Microsoft Word. Instead, ArcGIS is a true database management system and 

information and tasks can be shared with others easily and managed much more 

efficiently by subsequent users. This is true only if the careator has some forthought in the 

building of the database and appreciates and understands its functionality and how to 

account for unforseen circumstances or situations where the schema may need to be 

amended. 

 

Using the Attributes, one can then begin to create maps or other graphics and charts 

using “Definition Queries” like was performed in Session 1, or ‘styling options’ on the 

Symbology Pane at the right side of the screen. These queries and ‘styles’ can also be 

saved and then used again or edited slightly for other data, as needed. Once you begin 

to build your workflow, you an become more efficient and avoid the duplication of your 

own work. Simply apply what you have done to new features and data. 

 

  
62. Now, the layers can be styled based on Attributes, or queried as needed. 



In this session of ArcGIS Pro, you have seen how to create Feature Classes, and how to begin 

drawing and editing feature geometry. Later sessions will expand on various drawing tools and 

eventually, automatic feature extraction processes, but we have to understand how those types 

of processes and tools function to avoid creating problems for subsequent users. 

 

You also explored the Attribute Table and began making edits. You were also shown there were 

several different types of Save including saving the “Schema” of an Attribute Table, saving the 

Attribute Table edits, and saving of a Project. 

 

We will continue to build on editing tools including how to Split and Merge. We will also explore 

the use of the Trace tool. We will also edit more Attribute Data and display records accordingly 

using the Symbology options in future sessions. 

 

Submit your Session 1 Map to a peer in order to get credit for that Session, and then try to style 

the Trees in this Session 2 according to any attribute you wish, or a ‘Unique Value’. It could be 

using separate colors based on tree type, or it can be done using Graduated Circles or other 

shape, based on trunk size, or crown diameter.  

 

If you do not know how to style the points based on an attribute, explore the training found here:   

 

https://www.esri.com/training/catalog/5ca28d18780a171ba3ec188a/symbolizing-map-layers/ 

 

Then create and share a Layout of the trees with a peer.  


